• Slider Banner

    1

    天行健,君子以自强不息

    Read more
  • Slider Banner

    2

    万类霜天竞自由

    Read more
  • Slider Banner

    3

    恰同学少年,风华正茂;书生意气,挥斥方遒。

    Read more

在Vmware ESXi 主机上关闭无响应的虚拟机电源或者重新启动

  • 在 ESX 主机上关闭虚拟机电源。
  • 虚拟机无响应,且无法停止或终止。
  • 无法访问或解锁虚拟机上的文件。
  • 在关闭虚拟机后,vCenter Server 显示虚拟机已启动且正在运行。

  • 不指示虚拟机已关闭。

  • 无法在虚拟机中编辑属性。

  • 会显示以下错误中的一个或多个:
    • Soap error 999. The operation is not allowed in current state.
    • The attempted operation cannot be performed in the current state (Powered Off).
    • The request refers to an object that no longer exists or has never existed

 Purpose

本文提供了关闭(如果需要)或停止无响应的虚拟机的正确顺序。

标签

在 SUSE Linux 上安装 PostgreSQL 10.x

SUSE Linux Enterprise Server 12SP5 (PostgreSQL) 10.12

SUSE Linux Enterprise Server 12SP3 (PostgreSQL) 10.8

linux-137:/usr/local # zypper install postgresql-server postgresql
linux-137:/usr/local # psql --version
psql (PostgreSQL) 10.12

linux-137:/home # chown postgres:postgres ./psqldata/

linux-137:/home # su postgres
postgres@linux-137:/home> initdb -D /home/psqldata/
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

标签

Rome Wasn't Built in a Day

Rome Wasn't Built in a Day

标签

安装Apache和PHP7 在SUSE Linux Enterprise Server

 

zypper in apache2

zypper in apache2-mod_php7

Apache的默认文档根目录是/srv/www/htdocs/目录 , 而 Centos7 是/var/www/html

配置文件是/etc/apache2/httpd.conf。

配置存储在的/etc/apache2/conf.d /目录。

vi /etc/apache2/default-server.conf
Options All
控制目录访问

systemctl restart apache2
 

标签

Transcend SSD固态硬盘, 16 GB, SSD, SATA III接口, 内置, 工业用

Transcend HSD370 Half-Slim SSD

Transcend HSD370 Half-Slim 固态硬盘 (SSD) 在印刷电路板上具备高性能和优质闪存。 这些 Half-Slim SSD 采用前沿技术,可增强产品寿命和数据保留性能。 HSD370 最适合用于读取大应用和空间有限的移动设备,如工业控制系统、医疗设备、移动设备和 POS 终端

符合 RoHS
支持 TRIM 和 NCQ 功能
支持设备睡眠模式
高级全局磨损均衡和智能块管理,提供可靠性
内置 ECC(错误纠正代码)功能
带 DDR3 DRAM 缓存
支持高级垃圾收集和增强型 S.M.A.R.T. 功能
电源扩展板
支持安全命令
抗冲击和抗振性

固态驱动器

产品技术参数

属性数值

硬盘驱动器类型SSD

型号HSD370

内部/外部内部

工业是

形状系数SlimSATA

接口SATA III

容量16 GB

Nand 类型MLC

标签

xfs文件系统 支持64KB 块

linux-134:~ # mkfs.xfs -b size=64k /dev/sdb1
meta-data=/dev/sdb1              isize=512    agcount=4, agsize=3813376 blks
         =                       sectsz=4096  attr=2, projid32bit=1
         =                       crc=1        finobt=0, sparse=0, rmapbt=0, reflink=0
data     =                       bsize=65536  blocks=15253504, imaxpct=25
         =                       sunit=0      swidth=0 blks
naming   =version 2              bsize=65536  ascii-ci=0 ftype=1
log      =internal log           bsize=65536  blocks=7448, version=2

标签

Kubernetes 和 OpenShift

Kubernetes 是一个开源项目,而 OpenShift 是 Red Hat 提供的产品。实际上,OpenShift 是由 Origin Kubernetes Distribution (OKD) 提供支持的,它包括 Kubernetes 和其他开源项目,如 Docker、一个容器运行时环境,以及 Istio(如果您使用的是服务网格)。理解 Kubernetes 的基本原理是很重要的,其支持了 OpenShift。


对于中小企业没有容器平台研发能力,建议还是选择Openshift. 有研发能力的选择Kubernetes, 更加灵活定制开发。

Kubernetes 适应多种平台,

OpenShift 当然就是red hat系

标签

docker on suse linux 12sp5

linux-134:~ # docker pull registry.suse.com/suse/sles12sp5
Using default tag: latest
latest: Pulling from suse/sles12sp5
588a9fcc4a90: Pull complete
Digest: sha256:dbfcc66daee31b4b94cdc920c2446d4e4b44b2ba6bc3f121868ee0c2afa90ca0
Status: Downloaded newer image for registry.suse.com/suse/sles12sp5:latest
registry.suse.com/suse/sles12sp5:latest
linux-134:~ # sle2docker list
Available pre-built images:
No pre-built image found.

标签

基本超速缓存模式:写回、直写、绕写和直通

多层超速缓存使用的基本超速缓存模式:写回、直写、绕写和直通。

写回: 写入已超速缓存块的数据只会存入超速缓存,并且该块将标记为脏块。这是默认的超速缓 存模式。

直写 只有在同时命中源设备和超速缓存设备之后,向已超速缓存块的写入才会完成。在直写超 速缓存中,干净块将保持干净状态。

绕写 类似于直写超速缓存的一种技术,不过,写 I/O 将直接写入永久性储存,并绕过超速缓 存。这可以防止超速缓存因写 I/O 而填满,导致以后不可重新读取,不过,缺点是对最近 写入数据的读取请求会造成“超速缓存未命中”,因而需要从慢速大容量储存中读取这些数 据,致使发生较高延迟。

直通 要启用直通模式,超速缓存必须是干净的。将绕过超速缓存,从源设备为读取请求提供服 务。写请求将转到源设备,使超速缓存块“失效”。直通允许您激活超速缓存设备时不必考 虑数据一致性,而这是可以维护的。随着写操作的不断进行,超速缓存将逐渐变为冷状 39 超速缓存模式 SLES 12 SP5 态。如果您以后可以校验超速缓存的一致性,或者可以使用 invalidate_cblocks 讯 息来建立这种一致性,则可以在超速缓存设备仍处于暖状态时,将它切换到直写或写回模 式。或者,可以在切换到所需的超速缓存模式之前,先丢弃超速缓存内容。

 

标签

Acronis 在Linux 平台的安装方法

Linux 程序包

若要将必要的模块添加至 Linux 内核,安装程序需要以下 Linux 程序包:

  • 带内核头文件或内核源的程序包。程序包版本必须与内核版本相符。
  • GNU Compiler Collection (GCC) 编译器系统。GCC 版本必须是编译内核时所使用的版本。
  • Make 工具。
  • Perl 解释程序。
  • libelf-dev、libelf-devel 或 elfutils-libelf-devel 库用于开发内核(最低版本 4.15),并使用 CONFIG_UNWINDER_ORC=y 进行配置。对于某些发行版本(例如 Fedora 28),它们需要与内核标头分开安装。

这些程序包的名称可能随 Linux 的发行版本而异。

在 Red Hat Enterprise Linux、CentOS 和 Fedora 中,通常由安装程序来安装这些程序包。在其它发行版中,如果尚未安装这些程序包或是版本不对,您需要安装所需的程序包。

是否已安装所需的程序包?

如需检查是否已安装这些程序包,请执行以下步骤:

标签
订阅