• Slider Banner

    1

    天行健,君子以自强不息

    Read more
  • Slider Banner

    2

    万类霜天竞自由

    Read more
  • Slider Banner

    3

    恰同学少年,风华正茂;书生意气,挥斥方遒。

    Read more

基本超速缓存模式:写回、直写、绕写和直通

多层超速缓存使用的基本超速缓存模式:写回、直写、绕写和直通。

写回: 写入已超速缓存块的数据只会存入超速缓存,并且该块将标记为脏块。这是默认的超速缓 存模式。

直写 只有在同时命中源设备和超速缓存设备之后,向已超速缓存块的写入才会完成。在直写超 速缓存中,干净块将保持干净状态。

绕写 类似于直写超速缓存的一种技术,不过,写 I/O 将直接写入永久性储存,并绕过超速缓 存。这可以防止超速缓存因写 I/O 而填满,导致以后不可重新读取,不过,缺点是对最近 写入数据的读取请求会造成“超速缓存未命中”,因而需要从慢速大容量储存中读取这些数 据,致使发生较高延迟。

直通 要启用直通模式,超速缓存必须是干净的。将绕过超速缓存,从源设备为读取请求提供服 务。写请求将转到源设备,使超速缓存块“失效”。直通允许您激活超速缓存设备时不必考 虑数据一致性,而这是可以维护的。随着写操作的不断进行,超速缓存将逐渐变为冷状 39 超速缓存模式 SLES 12 SP5 态。如果您以后可以校验超速缓存的一致性,或者可以使用 invalidate_cblocks 讯 息来建立这种一致性,则可以在超速缓存设备仍处于暖状态时,将它切换到直写或写回模 式。或者,可以在切换到所需的超速缓存模式之前,先丢弃超速缓存内容。

 

标签

Acronis 在Linux 平台的安装方法

Linux 程序包

若要将必要的模块添加至 Linux 内核,安装程序需要以下 Linux 程序包:

  • 带内核头文件或内核源的程序包。程序包版本必须与内核版本相符。
  • GNU Compiler Collection (GCC) 编译器系统。GCC 版本必须是编译内核时所使用的版本。
  • Make 工具。
  • Perl 解释程序。
  • libelf-dev、libelf-devel 或 elfutils-libelf-devel 库用于开发内核(最低版本 4.15),并使用 CONFIG_UNWINDER_ORC=y 进行配置。对于某些发行版本(例如 Fedora 28),它们需要与内核标头分开安装。

这些程序包的名称可能随 Linux 的发行版本而异。

在 Red Hat Enterprise Linux、CentOS 和 Fedora 中,通常由安装程序来安装这些程序包。在其它发行版中,如果尚未安装这些程序包或是版本不对,您需要安装所需的程序包。

是否已安装所需的程序包?

如需检查是否已安装这些程序包,请执行以下步骤:

标签

mount smb fs in linux

SUSE 12.5 Linux

zypper install smb-client

smbtree 可用

mount -t cifs -o username=xinyong-dell  //192.168.11.60/Acronis /home/smb
Password for xinyong-dell@//192.168.11.60/Acronis:  ******

Fedora core 33.0:同上 不用提前输入密码

Ubuntu 18.04& Redhat & Centos V7 Linux:

apt install smbclient

mount -t cifs -o username=xinyong-dell,password=12345  //192.168.11.60/Acronis /home/smb

标签

ServeRAID M5110 and M5210 SAS/SATA Controllers

he ServeRAID M5110 and M5110e SAS/SATA controllers are 6 Gb SAS/SATA internal RAID controllers.

https://lenovopress.com/tips0857-serveraid-m5110-m5110e

The ServeRAID M5210 and M5210e SAS/SATA Controllers are high performance 12 Gb SAS controllers 

https://lenovopress.com/tips1069-serveraid-m5210-sas-sata-controller

标签

安装 卡巴斯基 在 Centos linux

kernel-devel-2.6.32-642.el6.i686
yum install kernel-headers-2.6.32-642.el6.i686
kernel-devel-2.6.32-642.el6.i686

标签

Gluster volume 编辑 on SUSE linux

gluster> volume info

Volume Name: vol00
Type: Distribute
Volume ID: 66a73e46-fabf-4cb3-b2b1-54b8f12dfc9c
Status: Started
Snapshot Count: 0
Number of Bricks: 3
Transport-type: tcp
Bricks:
Brick1: linux-acronis:/home/gvol
Brick2: linux-12sp5-1:/home/gvol
Brick3: linux-133:/home/gvol
Options Reconfigured:
performance.client-io-threads: on
nfs.disable: on
transport.address-family: inet
 

 

标签

suse 12SP5 安装Gluster 6.10 需要安装 python3-requests

SUSE 12SP5 安装GLUSTER 6.10 要点

rpm -ivh glusterfs-6.10-100.1.x86_64.rpm
warning: glusterfs-6.10-100.1.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 4b432c0e: NOKEY
error: Failed dependencies:
        python3-requests is needed by glusterfs-6.10-100.1.x86_64

提示需要安装 PYTHON3-REQUESTS

安装pip
python3 -m ensurepip --default-pip

升级pip
pip install --upgrade pip 

安装python3

zypper in python3 python3-base

安装python3-requests库 单单是这个还不够,gluster提示没有找到
python3 -m pip install requests

标签

deepsea stage run ceph.stage.0 1 2 3 4

node130:~ #  deepsea stage run ceph.stage.0
Starting orchestration: ceph.stage.0
Parsing orchestration ceph.stage.0 steps... â³

[parsing] on master
            |_ ceph.stage.0

[parsing] on node130.gbca.cn
            |_ ceph.salt.crc.master
               ceph.salt-api
               ceph.repo
               ceph.metapackage
               ceph.updates
               ceph.sync

标签

Python pip 安装与使用

pip 是 Python 包管理工具,该工具提供了对Python 包的查找、下载、安装、卸载的功能。

目前如果你在 python.org 下载最新版本的安装包,则是已经自带了该工具。

Python 2.7.9 + 或 Python 3.4+ 以上版本都自带 pip 工具。

pip 官网:https://pypi.org/project/pip/

你可以通过以下命令来判断是否已安装:

pip --version # Python2.x 版本命令 pip3 --version # Python3.x 版本命令

如果你还未安装,则可以使用以下方法来安装:

$ curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py # 下载安装脚本 $ sudo python get-pip.py # 运行安装脚本

标签

find 文件内容 注意引号

从根目录开始查找所有扩展名为.py的文本文件,并找出包含"deepsea-0.9.22"的行

find / -type f -name "*.py"  | xargs grep "deepsea-0.9.22"


find /usr/bin -type f -name "*"  | xargs grep "deepsea-0.9.22"

标签
订阅